#1 Independent Seller of WooCommerce Plugins
English

YITH Pre-Launch

4.58 out of 5 based on 12 customer ratings
12 customer reviews
How you can benefit from it: YITH Pre-Launch Plugin gives you the ability to set a simple Pre-Launch page for your under construction website. If you are launching your website and if you would like to make it clear to users, you can install this plugin to quickly set a lovely, customizable page, with a pretty countodown in real time.

YITH Pre-Launch Plugin gives you the ability to set a simple Pre-Launch page for your under construction website. If you are launching your website and if you would like to make it clear to users, you can install this plugin to quickly set a lovely, customizable page, with a pretty countodown in real time.

Reviews (12)

Customer reviews

Rated 4.58 out of 5 stars
12 reviews

Are you a customer? Submit your review

submit review
  1. 5 out of 5

    Liz dias - verified owner

    Muy bien!!Hace bastante bien su trabajo y es gratis, qué más se puede pedir

  2. 4 out of 5

    Richard García - verified owner

    Simple and freeis a basic plugin for every new ecommerce admin and is totally free. How could I not like it?

  3. 5 out of 5

    Valentino Morales - verified owner

    great and free!!amazing free plugin! I haven't found anything similar for free

  4. 5 out of 5

    David Mota - verified owner

    SencilloEfectivo y fácil de configurar, en cuestión de unos 20 min ya lo tenía todo listo

  5. 5 out of 5

    Aidan W. - verified owner

    great free toolexcellent free plugin, used it when my site was launching

FAQ

Here you can find some frequently asked questions about this plugin. If you can't find a reply to your doubts, ask a question: we will reply in a very short time
Topics:
  • All
  • General

Is it possible to set a countdown to show?

Yes, you can enable the Countdown option and set the date and style.

Can't find the answer?

Send us your question and we will reply very quick!

Send your question

Technical Info

  • Version: 1.2.0
  • Released: 2015-10-02
  •  
  • Minimum PHP version: 7.0
  • Requires: WordPress 3.5.1 or higher
  • Compatible up to: WordPress 4.3.x
  •  
  • Translation ready: YES
  • Support for: YITH Proteo theme. All YITH plugins.
97% CUSTOMER SATISFACTION

We don't offer one-time support, we care for you day-by-day.

Meet the team